WinOs.vip

网吧技术,我们的认真的!
QQ群:594362448
首页 » 未分类 » 锐捷NBR单臂路由IP分配教程

锐捷NBR单臂路由IP分配教程

一、组网需求
1、外网线路单根电信线路。
2、内网划分多个VLAN,但是内网只有二层的交换机,所以实现机制采用单臂路由方式实现。
3、内网有两个网段,192.168.10.0,192.168.20.0,分别对应划分vlan为:10,20。

二、配置要点
1、子接口名称填写范围是1至1023。
2、VLAN ID:相当于是封装的dot1Q,也就是说,填写的VLAN ID 要和下联交换机的VLAN ID 相对应。
3、1300G-E包含两个交换芯片口,命令行配置时要注意指定LAN口。

三、配置步骤
1、设备配置
首先,经过快速配置让设备自动下发nat的相关配置,然后在接口配置中选择内网口进行子接口的配置:
 
点击“子接口管理”进入子接口配置界面
 
子接口名称填写范围是1至1023
VLAN ID:相当于是封装的dot1Q,也就是说,这边填写的VLAN ID 要和下联交换机的VLAN ID 相对应
IP地址是下联交换机vlan的网关地址
 
生成的配置命令如下:
interface GigabitEthernet 0/0.10-----进入配置子接口1
encapsulation dot1Q 10-----封装子接口为VLAN10
ip nat inside-----定义为内网口
ip address 192.168.10.1 255.255.255.0-----配置子接口的IP地址
interface GigabitEthernet 0/0.20-----进入配置子接口2
encapsulation dot1Q 20-----封装子接口为VLAN20
ip nat inside-----定义为内网口
ip address 192.168.20.1 255.255.255.0-----配置子接口的IP地址
1300G-E产品命令行配置如下:
interface GigabitEthernet 0/0.10-----进入配置子接口1
encapsulation dot1Q 10-----封装子接口为VLAN10
ip nat inside-----启用内网口NAT
vlan port 0 2 tag-----把lan0-lan2口加入到该VLAN 10,tag表示lan口发送的报文会带上这个Vlan 10的tag,lan0-lan2口相当于TRUNK口(NBR1300G的G0/0默认情况下代表了LAN0-LAN2 等接口,所以子接口的配置与其它设备不一样一定要加上vlan port 0 2 tag子接口才可以正常通信) WEB界面配置会自动下发此命令;
ip address 192.168.10.1 255.255.255.0-----配置子接口的IP地址
interface GigabitEthernet 0/0.20-----进入配置子接口2
encapsulation dot1Q 20-----封装子接口为VLAN20
ip nat inside-----定义为内网口
ip address 192.168.20.1 255.255.255.0-----配置子接口的IP地址
vlan port 0 2 tag--------把lan0-lan2口加入到该VLAN 20,tag表示lan口发送的报文会带上这个Vlan 20的tag,lan0-lan2口相当于TRUNK口
2、交换机配置如下:
用配置线连接交换机,然后对交换机进行配置。
把交换机上16口跟路由器内网口相连的口配置为trunk。
Ruijie(config)#interface GigabitEthernet 0/16
Ruijie(config-GigabitEthernet 0/16)#switchport mode trunk
Ruijie(config-GigabitEthernet 0/16)#exit
在交换机创建VLAN 10 ,20,并把相关的接口划分到VLAN中。
Ruijie(config)#vlan  10
Ruijie(config-vlan)#exit
Ruijie(config)#vlan 20
Ruijie(config-vlan)#exit
Ruijie(config)#interface GigabitEthernet 0/13                                          //用户连接13号接口,配置ip为192.168.10.x网段
Ruijie(config-GigabitEthernet 0/13)#switchport access vlan  10
Ruijie(config-GigabitEthernet 0/13)#exit
Ruijie(config)#interface GigabitEthernet 0/14                                        //另外一个用户连接14号接口,配置ip为192.168.20.x网段
Ruijie(config-GigabitEthernet 0/14)#switchport access vlan  20
Ruijie(config-GigabitEthernet 0/14)#exit
Ruijie(config)#exit
Ruijie#wr

四、配置验证
1、用网线把交换机的16号接口连接EG路由器的内网口G0/0。
2、把电脑接到交换机的13号端口下,IP地址配置为:192.168.10.18  子网掩码:255.255.255.0,网关设置为:192.168.10.1。
 
3、测试是否可以正常上外网
然后在电脑上PING 网关看下是否可以通信:
 
4、在电脑上打开百度测试是否可以上网?
备注:vlan 20测试方法一样

文章如无特别注明均为原创! 作者: admin, 转载或复制请以 超链接形式 并注明出处 Winos.vip
原文地址《 锐捷NBR单臂路由IP分配教程》发布于2020-9-25

评论

游客

切换注册

登录

您也可以使用第三方帐号快捷登录

Q Q 登 录
微 博 登 录
切换登录

注册

sitemap