WinOs.vip

网吧技术,我们的认真的!
QQ群:594362448
首页 » 未分类 » 易语言遍历文件夹及子文件夹下面所有的文件

易语言遍历文件夹及子文件夹下面所有的文件

1.这里用到的是模块里面的“文件_枚举1()”,注意不是“文件_枚举()”,“文件_枚举()”这个只能枚举一级目录,即子目录下面的枚举不出来。看代码:

.版本 2

.支持库 spec

.子程序 _按钮1_被单击

文件_枚举1 (“F:新建文件夹”, “*.*”, &子程序1)

.子程序 子程序1

.参数 目录, 文本型

.参数 文件名, 文本型

调试输出 (目录 + 文件名)

2.看看调试结果,已经可以调试出所有文件了,并且已经可以多级子目录枚举了

3.我的演示是把路径也带上了,如果你只需要文件名,那就这样“调试输出 (文件名)”即可,是不是很棒很简单?!
注意事项
注意需要用到“文件_枚举1()”,“文件_枚举()”这个只能枚举一级目录,即子目录下面的枚举不出来!

如遇到无法下载,请扫码加我,留言。能修复的,第一时间修复后,微信回复。 本站还开通了VIP专属下载通道,15元一个月!需要联系微信开通!

文章如无特别注明均为原创! 作者: admin, 转载或复制请以 超链接形式 并注明出处 Winos.vip
原文地址《 易语言遍历文件夹及子文件夹下面所有的文件》发布于2022-8-29

评论

游客

切换注册

登录

您也可以使用第三方帐号快捷登录

Q Q 登 录
微 博 登 录
切换登录

注册

sitemap