WinOs.vip

网吧技术,我们的认真的!
QQ群:594362448
首页 » 未分类 » 易语言取外网ip的两种方法
分类:

易语言取外网ip的两种方法

文章作者:admin
手机扫码查看

办站宗旨:收集和分享一些实用的工具,好用的网吧系统,解决问题经验等,保证都是非常实用的工具。做这个博客,我一直把用户体验放在第一位。

易语言取外网ip的两种方法



方法1:
.版本 2
.支持库 internet
 .子程序 取外网ip_文本操作, 文本型
.局部变量 内容, 文本型
.局部变量 开始位置, 整数型
.局部变量 长度, 整数型
.局部变量 网址, 文本型
.局部变量 开始标识符, 文本型
.局部变量 结束标识符, 文本型
 网址 = “http://www.net.cn/static/customercare/yourIP.asp”
开始标识符 = “<h2>”
结束标识符 = “</h2>”
内容 = 到文本 (HTTP读文件 (网址))
开始位置 = 寻找文本 (内容, 开始标识符, , 假) + 取文本长度 (开始标识符)
长度 = 取文本长度 (内容) - 取文本长度 (开始标识符) - 寻找文本 (内容, 开始标识符, , 假) - (取文本长度 (内容) - 寻找文本 (内容, 结束标识符, , 假))
返回 (取文本中间 (内容, 开始位置, 长度))
方法2:

.版本 2
.支持库 RegEx
.支持库 internet
 .子程序 取外网ip_正则操作, 文本型
.局部变量 开始标识符, 文本型
.局部变量 结束标识符, 文本型
.局部变量 正则, 正则表达式
.局部变量 结果, 搜索结果
.局部变量 内容, 文本型
.局部变量 网址, 文本型
 开始标识符 = “<h2>”
结束标识符 = “</h2>”
网址 = “http://www.net.cn/static/customercare/yourIP.asp”
正则.创建 (开始标识符 + “(.*?)” + 结束标识符, 假)
内容 = 到文本 (HTTP读文件 (网址))
结果 = 正则.搜索 (内容, 1, )
返回 (结果.取子匹配文本 (内容, 1, ))

如遇到无法下载,请扫码加我,留言。能修复的,第一时间修复后,微信回复。 本站还开通了VIP专属下载通道,15元一个月!需要联系微信开通!

文章如无特别注明均为原创! 作者: admin, 转载或复制请以 超链接形式 并注明出处 Winos.vip
原文地址《 易语言取外网ip的两种方法》发布于2022-9-23

评论

游客

切换注册

登录

您也可以使用第三方帐号快捷登录

Q Q 登 录
微 博 登 录
切换登录

注册

sitemap