WinOs.vip

网吧技术,我们的认真的!
QQ群:594362448
首页 » 未分类 » 易语言遍历目录及子目录下面的所有目录

易语言遍历目录及子目录下面的所有目录

有时候我们需要用到目录遍历这个功能,比如说找出一个文件夹及子文件夹下面所有空文件夹并删除,这时候就要用到易语言目录遍历了。网上搜到的都是一些递归调用子程序的解决方法,好复杂,我等菜鸟直接用不上,PASS,下面看个简单的。

使用工具
易语言软件
精易模块
1.自己新建几个文件夹试试呗。

直接贴出代码:

.版本 2
 
.支持库 spec
 
.子程序 _按钮2_被单击
 
.局部变量 数组, 文本型, , "0"
 
目录_枚举子目录1 (“F:\新建文件夹”, 数组, 真, 真)
 
调试输出 (数组)



2.注意:这里我们是用的模块里面的“目录_枚举子目录1()” 而不是“目录_枚举子目录()”,目录_枚举子目录()这个只能遍历一级目录,子目录遍历不出来!
3.看看效果:已经可以遍历文件夹及子文件夹了,是不是很简单



注意事项
实现遍历目录及子目录需要用到模块的“目录_枚举子目录1()”命令!不是“目录_枚举子目录()!”

如遇到无法下载,请扫码加我,留言。能修复的,第一时间修复后,微信回复。 本站还开通了VIP专属下载通道,15元一个月!需要联系微信开通!

文章如无特别注明均为原创! 作者: admin, 转载或复制请以 超链接形式 并注明出处 Winos.vip
原文地址《 易语言遍历目录及子目录下面的所有目录》发布于2022-9-23

评论

游客

切换注册

登录

您也可以使用第三方帐号快捷登录

Q Q 登 录
微 博 登 录
切换登录

注册

sitemap